Frage Linux-ck Kernel auf ArchLinux mit Gummiboot aktivieren


Dies ist meine erste ArchLinux-Installation und ich versuche, linux-ck kernel auf meinem ArchLinux (als VirtualBox-Gast) auszuführen, der den Gummiboot-Bootloader verwendet. Gemäß Dies Anleitung, die ich installiert habe linux-ck-ivybridge virtualbox-ck-guest-modules-ivybridge Pakete, dann habe ich hinzugefügt elevator=bfq Kernel-Parameter zu /boot/loader/entries/arch.conf so sieht es jetzt so aus:

# cat /boot/loader/entries/arch.conf 
title   Arch Linux
linux   /vmlinuz-linux
initrd  /initramfs-linux.img
options root=/dev/sda1 rw quiet elevator=bfq

Dann bin ich gelaufen gummiboot update. Nach dem Rebbot, uname -r gibt mir immer noch 3.12.8-1-ARCH und dmesg | grep scheduler sagt mir das "[ 0.520294] I/O scheduler bfq not found".

Gemäß DiesEs scheint, dass der Bootloader auf den neuen Kernel aufmerksam gemacht werden muss, jedoch werden nur Anweisungen für grub gegeben. Ich habe keinen besonderen Grund, Gummiboot anstelle von Grub zu verwenden, aber ich befürchte, dass der Versuch, Grub jetzt zu installieren, mein System durcheinander bringen würde. Die Frage ist also, wie kann ich gummiboot auf den ck-Kernel aufmerksam machen (und laden)? Alternativ, wie kann ich gummiboot sicher durch grub ersetzen? Danke im Voraus!


2
2018-01-20 21:21


Ursprung




Antworten:


Ok, ich habe die Lösung gefunden ... Ich musste einen neuen Eintrag erstellen in /boot/loader/entries/ so aussehen:

title   Arch Linux CK
linux   /vmlinuz-linux-ck
initrd  /initramfs-linux-ck.img
options root=/dev/sda1 rw quiet elevator=bfq

und nun uname -r Berichte 3.12.8-1-ck

und dmesg | grep scheduler Berichte BFS CPU scheduler v0.444 by Con Kolivas.

Ich hoffe, dass dies anderen helfen könnte.


3
2018-01-20 21:33