Frage Kann Matplotlib nicht in Cygwin installieren (Freetype-Problem)


Es wäre wirklich schön, Matplotlib in meiner Cygwin-Umgebung zu haben. Ich habe 64-Bit-Windows 8 mit 64-Bit-Cygwin.

Wenn ich tippe:

pip install matplotlib

Ich erhalte folgende Fehlermeldung:

 * The following required packages can not be built:
 * freetype

Laut apt-cyg habe ich folgende Pakete bereits installiert:

Searching for installed packages matching freetype: 
cygwin32-freetype2
freetype2-debuginfo
libfreetype-devel
libfreetype-doc
libfreetype6

Was braucht es noch? Wie installiere ich Freetype & Matplotlib richtig?


4
2018-06-18 00:25


Ursprung




Antworten:


Ich hatte das gleiche Problem auf Windows 7 64-Bit; Ich habe es gelöst, indem ich die Cygwin-Pakete installiert habe pkg-config und libX11-devel vor dem Tippen easy_install matplotlib==1.1.1 (Die Version 1.3.1 hat Fehler auf meiner Maschine, daher die 1.1.1).


9
2017-07-23 12:24



Danke für den Vorschlag, ich werde es versuchen. Für mich verwende ich Matplotlib außerhalb von Cygwin (normale Windows-Installation). - Alexey Petrenko


Ich hatte auch das gleiche Problem auf Cygwin Windows 8 64-Bit. Ich folgte dem Rat in einer anderen Antwort (installieren pkg-config und libX11-devel) aber das Paket, mit dem ich Matplotlib endlich installieren konnte, war libfreetype-devel. Dann einfach easy_install matplotlib==1.4.2.


3
2017-12-24 16:54