Frage Wie installiert man das Pyspark-Plugin in PyCharm?


Wenn ich versuche zu installieren pyspark plugin im PyCharmIch erhalte einen Fehler Make sure that you use the correct version of 'pip' installed for your Python interpreter located at '/usr/bin/python2.7' Allerdings, wenn ich tippe pip --version Im Terminal sehe ich diese Version:

pip 8.1.2 from /usr/local/lib/python2.7/dist-packages (python 2.7)

Also, kann nicht herausfinden, was ich falsch mache.


0
2017-09-21 09:25


Ursprung




Antworten:


PyCharm kann mehr als einen Interpreter haben. Wenn Sie pip über die Befehlszeile ausführen, sucht das System anhand der PATH-Einstellungen den ersten gefundenen Pip, nicht unbedingt den, den Sie in PyCharm verwenden.

In den Einstellungen -> Projekt oben wird ein Drop-Down der Python-Interpreter angezeigt. Klicken Sie auf das Drop-down-Menü und zeigen Sie alle an. Stellen Sie dann in einem Terminalfenster sicher, dass für jeden ein Pip vorhanden ist.

enter image description here

Sie würden dies tun, indem Sie das Modul "securepip" mit jedem Python ausführen. Also in meinem Beispiel hervorgehoben würde ich laufen

/usr/local/Cellar/python3/3.5.1/Frameworks/Python.framework/Versions/3.5/bin/python3 -m ensurepip

um sicherzustellen, dass ich pip für diese Version von Python habe. Tue es ähnlich für die anderen Pythons von Interesse.


0
2017-09-22 02:06