Frage Windows 10 Search kann keine Anwendungen finden. Sogar Taschenrechner [duplizieren]


Diese Frage hat hier bereits eine Antwort:

Ich habe ein Problem mit Windows 10 Enterprise N x64. Wenn ich "Start" drücke und anfange, den Anwendungsnamen einzugeben, wird es nie gefunden.

Ich kann nicht einmal Anwendungen wie "Rechner", "Microsoft Word" oder andere finden. Ich bewegte nur Punkte und ließ es 30 Minuten ohne Erfolg laufen.

PS. Es besteht die Möglichkeit, dass dies für Sie nicht funktioniert, wenn Sie ein Upgrade statt einer Neuinstallation von Windows 10 durchführen. Aber Sie können es immer versuchen.

Dies sind meine Indizierungsoptionen. Indexing Options


159
2017-07-30 08:26


Ursprung


Sieht so aus, als wäre ich nicht der Einzige mit diesem Problem! Kann nicht auf die Antwort warten .. - xstnc
@xstnc Ich habe meine eigene Antwort gepostet (ich kann sie jetzt nicht akzeptieren), die ich durch das Lesen von Beiträgen zu ähnlichen Problemen in früheren Windows-Versionen herausgefunden habe. Du kannst es versuchen. Es hat für mich funktioniert. - Hooch
Zuerst schien ich nichts für mich zu tun. Ich habe keinen Neustart versucht. Ich werde später nachschauen und upvote, wenn es geholfen hat! @Fusel - xstnc
Da ich eine Menge Probleme mit der Windows 10-Suche habe, habe ich gepostet dieser Feature-Vorschlag. Wenn Sie hier enden, möchten Sie vielleicht darüber abstimmen. - Jesko Hüttenhain
Ich habe festgestellt, dass, wenn Sie zu C: \ ProgramData \ Microsoft \ Windows \ Startmenü \ Programme gehen und die Verknüpfung "Suchen" öffnen, öffnet es die "Search Everywhere" -Funktion von Win 8, und dort erscheinen alle Apps, so hat es ein Fehler in der neuen Suchoberfläche von Win 10 sein und nicht in den Indizierungsoptionen. Ich wünschte nur, dass "wins + s" anstelle von Cortana "Search Everywhere" öffnen könnte. - Augusto Barreto


Antworten:


Ich habe keine Ahnung warum oder was ich dabei gebrochen habe. Aber hier hat was für mich funktioniert.

  1. Strg + Umschalt + Rechtsklick auf einen leeren Teil der Taskleiste und Klick auf "Exit Explorer" (oder über Task-Manager beenden, falls das nicht funktioniert).

  2. Löschen Sie diesen Registrierungsschlüssel.

HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Windows \ AktuelleVersion \ Explorer \ FolderTypes \ {ef87b4cb-f2ce-4785-8658-4ca6c63e38c6} \ TopViews \ {00000000-0000-0000-0000-000000000000}

  1. Starten Sie den Prozess Explorer.exe über den Task-Manager.

Dies ist eine von vielen Antworten hier. Fühlen Sie sich frei, die Vorschläge anderer Leute auszuprobieren. Wenn Sie alle Antworten in einem kombinieren, akzeptiere ich Ihre Antwort.

enter image description here


Methode für das Update des Erstellers Auschecken Dies Antworten.


95
2017-07-30 09:27



Für mich funktioniert nicht: / - Ev0oD
Explorer einfach zu töten und neu zu starten hat es für mich getan. Erweiterte Anweisungen für das Zurückbringen Ihrer Taskleiste bei superuser.com/a/313998/197108 - Noumenon
Das hat für mich funktioniert, aber kann ich nur darauf hinweisen, wie bizarr es ist - Jared Beach
Bitte rate den Leuten nicht, explorer.exe zu beenden, wenn sie noch antwortet. Empfehlen Sie ihnen stattdessen, den Explorer zu verlassen. In Windows 10 geschieht dies (anscheinend) mit Strg + Umschalt + Rechtsklick auf einen leeren Teil der Taskleiste und Klick auf "Exit Explorer". Diese Eigenschaft existiert für genau diese Art von Dingen. - Kevin Cathcart
Netter Schreibfehler im Screenshot: D - Matthew Cawley


Hier eine Lösung gefunden: Cortana findet keine Desktop-Apps, wenn sie nach ihnen suchen

Hier ist der relevante Teil:

Ich habe es neu installiert Cortana Verwenden Sie das folgende Verfahren:

  1. Öffnen Sie ein Eingabeaufforderungsfenster mit erhöhten Rechten (drücken Sie auf + X und dann auf A)
  2. Art start powershell und drücke Enter
  3. Führen Sie den Befehl (in einer Zeile) aus:

    Get-AppXPackage -Name Microsoft.Windows.Cortana | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}
    

Nach 30 Sekunden war das Problem auf meinem Rechner gelöst. Unglaublich.


72
2017-08-12 03:26



Hat super für mich gearbeitet - Dan Revell
Das gleiche Verhalten war auch anders als bei OP, weil ich Standard-Apps finden würde, aber keine, die ich installiert hatte (wie Word, Excel usw.) und die ich in der Liste Alle Apps finden konnte. Das hat es für mich repariert, danke! - DannyT
Es mag absurd erscheinen, aber das hilft auch wenn Cortana wird NICHT unterstützt in deiner Sprache oder deinem Land. Probieren Sie es einfach aus. - Radek Pech
+1 Das hat bei mir funktioniert. WTF-Fenster. Dies zu beheben sollte nicht 2 Tage dauern! - Anshul
Diese Frage war ungefähr Windows Search Nicht Cortana. Ich habe samen Problem, aber ich stoppte und deinstalliert cortana , ich benutze die Normail Windows Suche jetzt - Sam Nikzad


Deaktivierung der "Lassen Sie Apps im Hintergrund laufen"toggle auf"Hintergrund Apps"Die Seite der neuen Windows-Datenschutzeinstellungen bewirkt, dass die Startmenüsuche unterbrochen wird. zumindest unter Windows 10 mit dem Creator's Update!

Ich habe kürzlich Windows 10 mit dem Creator's Update auf drei Rechnern neu installiert. Nach der Installation von Windows war mein erster Schritt auf allen Maschinen, durch alle Seiten darunter zu klicken die Einstellungen -> Privatsphäre, Deaktivieren jedes einzelnen Toggle. Unter diesen war der "Lassen Sie Apps im Hintergrund laufen"Einstellung auf die Hintergrund Apps Seite.

Bald danach bemerkte ich, dass neu installierte Anwendungen nicht in der Startmenü-Suche angezeigt wurden - entweder durch win+S oder einfach mit dem Tippen beginnen, wenn das Startmenü den Fokus hatte. Auf allen Maschinen würden einige Ergebnisse angezeigt und andere würden fehlen. Neu installierte Sachen würden nicht angezeigt. Zum einen tippen google oder chrom würde nichts als das volle Wort ergeben, chrome, würde "Befehl ausführen" anzeigen. An einem Punkt würde eine Maschine nur vervollständigen notepadund das Ergebnis konnte nicht angeklickt oder aktiviert werden.

Dieser Thread half mir zu erfahren, dass das Erstellen eines neuen lokalen Administrator-Benutzers auf den Computern das Problem vorübergehend beheben würde - danke! Leider würde das Problem wieder auftreten und so versuchte ich herauszufinden, wann genau es begann. Ich tat dies mit einem Prozess, der viele, viele Neustarts und wiederholte Installation und Deinstallation umfasste 7-zip.

Ich war erfreut zu entdecken, dass meine Registry-Hacks, die Cortanas Web-Suche und Windows-Store-Suche deaktivieren, waren nicht verantwortlich - sie waren meine erste Vermutung. Das Aushacken anderer Teile von Windows hat die Suche nicht unterbrochen; Auch mein Power-Shell-Skript, das alle mit Windows 10 gelieferten Bloatware deinstalliert: Facebook, Twitter, XING, Keeper, die Liste geht weiter. (Dieser Vorgang wird automatisch erneut installiert, wiederholt und für neue Benutzerkonten neu installiert.)

Schließlich habe ich das Problem auf diese Datenschutzeinstellung aufmerksam gemacht - eine weitere Sache, die benutzerkontenspezifisch ist!

Meine Tests zeigen, dass Sie immer noch deaktivieren können, dass alle Anwendungen im Hintergrund ausgeführt werden, solange der primäre Schalter an der Spitze der "Hintergrund Apps"Seite bleibt Auf. Hier ist ein Screenshot meiner Einstellungen mit der Startmenü-Suche:

Working Privacy Settings

Alle anderen Datenschutzschalter können auf allen anderen Seiten ausgeschaltet werden.

Und schließlich scheint es, dass wenn "Lassen Sie Apps im Hintergrund laufen"Umschalten ist ausDurch erneutes Einschalten und Neustarten scheint die Suche nach dem Startmenü zu funktionieren, obwohl es eine Weile dauert, bis die Ergebnisse wieder 100% ergeben.

Von den in dieser Frage aufgelisteten Lösungen funktionierte nur der Vorschlag, ein neues lokales Benutzerkonto anzulegen und das erst, bis ich dieses problematische Umschalten wieder ausgeschaltet habe.


Wenn die Option "Apps im Hintergrund ausführen" nicht angezeigt wird, können Sie sie weiterhin über die Registrierung aktivieren. Um dies zu tun;

  1. Drücken Sie Windows-Logo-Taste + R, um den Laufdialog zu öffnen. Geben Sie "regedit" ein und drücken Sie die Eingabetaste.
  2. Navigieren Sie zu folgendem Schlüssel: HKEY_CURRENT_USER \ Software \ Microsoft \ Windows \ CurrentVersion \ BackgroundAccessApplications
  3. Rechtsklick auf HintergrundAccessApplicationsund wählen Sie Neu -> DWORD (32-Bit) Wert. Benenne es GlobalUserDisabled und setze seinen Wert auf 0.
  4. Neustart.

65
2018-05-13 15:47



Vielen Dank. Dies funktionierte für mich mit dem Update des Schöpfers. - jordanbtucker
DANKE! Absoluter Lebensretter. Microsoft ist manchmal so frustrierend. - anon58192932
Wurde dies zur Verbindung gesendet? - Marlon
Danke einen Haufen! +1 gute Antwort - esp für auch zu erwähnen, dass die Registry Tweaks nicht verantwortlich waren. Ich habe auch ein neues Profil erstellt .. - Jeremy J Wong
Nun, diese Benutzeroberfläche macht keinen Sinn. Jeder würde erwarten, dass ein Hauptschalter über mehreren spezifischeren Schaltern angeordnet wird, um nur diese Schalter zu steuern, und nicht irgendeine völlig unabhängige und grundlegende Funktion des Betriebssystems. Es ist Microsoft, Microsoft zu sein, denke ich. - Arno


Für diejenigen, die ihren Weg hierher finden, aber für die die akzeptierte Antwort nicht funktioniert, habe ich diese Art von Anwendung gesucht, um mit den folgenden Schritten zu arbeiten:

  1. Gehen Sie zu Indexierungsoptionen in der Systemsteuerung (Sie können einfach nach 'Index' suchen).
  2. Klicken Sie auf die Schaltfläche Ändern, um das Fenster Indizierte Orte anzuzeigen.
  3. Erweitern Sie Ihre Betriebssystemfestplatte und aktivieren Sie die Kontrollkästchen für Programme und Programmdateien (x86).

Es kann einige Minuten dauern, bis alles so funktioniert, wie Sie es sich wünschen.


23
2017-08-04 20:21



7 und 8 scheint dies zu tun, indem automatisch C: \ Users \ <Benutzer> \ AppData \ Roaming \ Microsoft \ Windows \ Startmenü in indizierten Positionen, und 10 nicht. Also meine Methode wie oben beschrieben ist eine Art Brute-Force-Methode, aber ich wählte es, weil ich manchmal Dinge ohne eine Option "Zum Startmenü hinzufügen" installieren (was diese Anwendung noch nützlicher macht). - Karim Temple
Für mich war alles korrekt. - Hooch
@KarimTemple - Sir, Sie haben den Leuten geraten, die Suche zu benutzen ("[...] Sie können einfach nach 'index' suchen [...]) in Ihrer Antwort auf eine Frage, die erklärt, dass op nichts findet in der Suche ... lol - WoIIe
@ Wolle Guter Punkt! Es tut uns leid! Ich konnte nach Indexierungsoptionen suchen, daher denke ich, dass mein Problem etwas anders war. - Karim Temple
Ich hatte dieses Problem bei einer Upgrade-Installation von Win10 von Win8.1 und auch auf einem anderen Rechner mit neuer Win10-Installation. Ich könnte nach 'index' suchen, wie @KarimTemple gefunden wurde. - AnneTheAgile


Wie ich mein Problem gelöst habe:

Der Service Windows Search war irgendwie deaktiviert, ich glaube ich habe es deaktiviert mit msconfig ohne die Konsequenzen zu kennen.

Versuche jedoch zu laufen services.msc und stellen Sie sicher Windows Search ist aktiviert und gestartet. Sie sollten das Ergebnis sofort sehen.

Viel Glück!


8
2017-08-07 13:35



Das habe ich entdeckt. Die Windows-Suche ist in Windows 10 standardmäßig deaktiviert. - ironywrit
Das war genau das Problem für mich auch, auf einer frischen Windows 10-Installation. Der Windows Search-Dienst wurde deaktiviert. Es war jedoch nicht die Schuld von Windows, es war die Software "Samsung Magician", die mit Samsung SSDs ausgeliefert wurde. Es deaktiviert den Windows Search-Dienst als Teil seiner Optimierungen. - jlh
@ironywrit: Es ist tatsächlich standardmäßig aktiviert (automatische Startverzögerung). - surfasb


Ich hatte das gleiche Problem. Meine Lösung dafür war zu gehen Indexierungsoptionen, wähle Fortgeschritten, dann wählen Sie Rebuild the index. Das hat es sofort behoben.


7
2017-08-04 23:45



Hat mir nicht geholfen. Ich habe diese Option versucht. Aber vielleicht wird es für andere funktionieren. Das sieht viel mehr wie ein wirklich komplexes Problem aus. - Hooch
Das hat das Problem für mich gelöst. - Billy


Ich füge nur eine Zusammenfassung basierend auf meiner eigenen Erfahrung hinzu.

Augustos Antwort funktioniert für mich nur vorübergehend. Installieren Sie einfach Cortana neu. Gehe zu Powershell und tippe ein

Get-AppXPackage -Name Microsoft.Windows.Cortana | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

Nach einer Weile ging das Zeug so, wie es einmal war. Manchmal, wenn ich zend tippe, wird zend studio angezeigt. Manchmal nicht.

Ich benutze auch einen der Kommentare als eine andere Antwort für den Fall, dass das nicht für Sie funktioniert.

Ich fand, dass, wenn du gehst C:\ProgramData\Microsoft\Windows\Start Menu\Programs und öffne die Verknüpfung "Suchen", es öffnet die "Suche überall" -Funktion von Win 8, und dort erscheinen alle Apps, also muss es ein Fehler in der neuen Suchoberfläche von Win 10 sein, und nicht in den Indizierungsoptionen. Ich wünschte nur, dass "wins + s" anstelle von Cortana "Search Everywhere" öffnen könnte. - Augusto Barreto 11. August um 17:52 Uhr

Das ist wieder im August geschrieben. BEIDE davon funktioniert für mich.

Ich habe Index und andere Lösungen neu erstellt. Das hat nicht funktioniert oder nur vorübergehend funktioniert.

Danke Augusto. Ich denke, ich sollte meine eigene Antwort hinzufügen, damit jeder weiß, welche Lösungen in meinem Fall und wahrscheinlich auch in ihren Fällen funktionieren.


7
2017-10-20 04:23





Lokales Administratorkonto war das Problem

Ich habe ein Windows 10 Pro SOE basierend auf x64 1607 erstellt, als ich auf die Suche nach dem Startmenü stieß und keine Anwendungen fand.

Um genau zu sein, wie oben in einigen Posts erwähnt, konnte ich voreingestellte vorinstallierte Anwendungen finden, aber nichts Neues, z. Wenn ich Adobe Acrobat Reader DC installiert habe, bekomme ich keine Ergebnisse, wenn ich nach "Adobe" oder "Acrobat" oder "Reader" suche.

Ich habe alle obigen Vorschläge ausprobiert, aber leider hat nichts funktioniert.

Ich erkannte, dass das Problem speziell auf das lokale lokale Administratorkonto zurückzuführen war. Als ich dasselbe mit mehreren neuen Benutzern auf dem System versuchte, funktionierten meine Suchen wie erwartet. Ich vermute, dass es damit zusammenhängt, dass einige UWP-Apps (calc, edge) nicht unter dem lokalen Administratorkonto laufen können, vielleicht ist Cortana / Windows Search für den lokalen Administrator kaputt.


3
2017-12-08 05:35



Ja. Hier gilt das gleiche. Aber wie löst man das? - Leonel
Das Problem ist Cortana. Wenn es nicht aktiviert ist oder nicht funktioniert, funktioniert die Suche nicht. In meinem Fall war es nicht aktiv, weil mein Windows in Englisch ist, aber meine Standorteinstellungen waren für Brasilien. Sobald ich es in die Vereinigten Staaten geändert habe, hat alles funktioniert. - Leonel
Erstellen eines neuen lokalen Benutzerkontos tut Lösen Sie das Problem, aber der Grund dafür ist, dass das neue Benutzerkonto den Standard hat "Privatsphäre"Einstellungen. Ich habe festgestellt, welche davon mit dem Problem zusammenhängt - siehe meine neue Antwort. (Auch bei dem neuen Benutzerkonto wird durch das Deaktivieren der betreffenden Einstellung das Problem erneut auftreten.) - Xharlie