Frage Wo ist der Syntaxfehler in meiner Formel?


Ich versuche, diese Formel zu verwenden, aber Excel sagt mir immer wieder, dass ein Fehler vorliegt.

=SI(NB.SI(A2;"*D*");"Data";"SI(NB.SI(A2;"*V*");"Voice";"Autres")")

(Auf Englisch:

=IF(COUNTIF(A2;"*D*");"Data";"IF(COUNTIF(A2;"*V*");"Voice";"Autres")")

)

Ich verstehe nicht, wo es ist.

SI bedeutet IF, ich verwende eine französische Version in Excel 2010 unter Win7.

Da mein Englisch nicht perfekt ist, könnten einige Dinge seltsam klingen.

Hier ist eine Demo von dem, was ich mache:

Screeenshot

  • WENN Dx Geben Sie Daten ein
  • IF Vx Tippen Sie auf Sprache
  • Wenn noch etwas anderes, Typ Autres.

x ist eine Nummer. Es gibt keine anderen Typen, nur "Data", "Voice" und "Autres".

Es kann meine eigene Formel sein, die falsch ist, wenn Sie eine andere Möglichkeit haben, dies einzugeben, fühlen Sie sich frei, dies zu tun.


0
2018-02-02 21:00


Ursprung


Welche Fehlermeldung haben Sie? Tut NB.SI bedeuten COUNTIF? Es gibt mehrere seltsam platzierte Klammern () und zitieren " Zeichen in Ihrer Formel. Ohne einige Beispieldaten zu sehen (hoffentlich mit einer Erklärung, was die Formel tun sollte), ist es nicht möglich, Ihnen zu sagen, wie die richtige Formel aussehen würde, - Máté Juhász
Ich denke, das doppelte Zitat direkt nach SI (NB.SI (A2; "D"); "Data") und ähnlich, bevor die endende Klammer nicht erforderlich ist - pat2015
Ich habe meinen Beitrag bearbeitet. Danke für deine Antwort ! - Darksoulpk68
Darksoulpk68, ich bin froh zu sehen, dass dein Problem gelöst wurde! Bitte denken Sie daran, nach der obligatorischen 2-tägigen Wartezeit zurückzukehren, um Ihre eigene Antwort als offizielle Lösung zu markieren. - Run5k


Antworten:


Ich habe nicht die französische Version, also kann ich nicht ausschließen, dass SI und NB.SI gut oder schlecht sind. Angenommen, sie sind gut, hier ist die Formel aufgeschlüsselt:

=SI
(
  NB.SI
  (
    A2;
    "D"              
  );                 *
  "Data";
  "SI                <
  (
    NB.SI
    (
      A2;
      "V"            
    );               *
    "Voice";
    "Autres"
  )"                 <
)

Dies sagt mir, es gibt zwei "das sind inkorrekt. Diese sind oben mit dem <markiert. Darüber hinaus ist die NB.SI-Formel unvollständig. NB.SI wird die Anzahl der Übereinstimmungen zurückgeben, aber IF prüft nur für ein wahr falsch, so Wir müssen die Anzahl der Übereinstimmungen in einem True oder False ändern, indem wir auswerten, ob sie mehr als 0 sind. Diese werden oben mit einem * hervorgehoben.

Die richtige Formel wäre

=SI
(
  NB.SI
  (
    A2;
    "D"
  )>0;
  "Data";
  SI
  (
    NB.SI
    (
      A2;
      "V"
    )>0;
    "Voice";
    "Autres"
  )
)

oder:

=SI(NB.SI(A2;"D")>0;"Data";SI(NB.SI(A2;"V")>0;"Voice";"Autres"))

3
2018-02-02 21:24



Das ist eigentlich eine Art Arbeit, aber die einzige Antwort ist "Autres". In Zeile A kann ich entweder Dxx oder Vxx haben. xx steht für Zahlen. Ich möchte die Zelle analysieren und mir sagen: "Wenn es D enthält, geben Sie Data ein, wenn es V enthält, geben Sie Voice ein, wenn es noch etwas enthält, geben Sie Autres ein. - Darksoulpk68
Deine Frage enthielt das nicht. Wie sollte ich wissen, was Sie genau brauchen? Bevor Sie Ihre nächste Frage beantworten, bearbeiten Sie bitte Ihre Frage so, dass sie alles enthält, was Sie benötigen. - LPChip
Ich habe es bearbeitet. Ich habe meine Frage zu schnell eingegeben. Es tut mir leid: / Ich habe auch einen Screenshot meines Excel-Arbeitsblattes beigefügt. Danke für Ihre Hilfe :) - Darksoulpk68
@ Darksoulpk68 Ich habe meine Antwort entsprechend bearbeitet. - LPChip


= IF (COUNTIF (A2, "D *"), "Daten", IF (COUNTIF (A2, "V *"), "Stimme", "Autres"))

Auf Französisch Folgendes nach dem Update:

=SI(NB.SI(A2;"D*");"Data",SI(NB.SI(A2;"V*");"Voice";"Autres")) 

Vielleicht sollten Sie SI anstelle von NB.SI verwenden, wenn Ihre Daten in A2 nur D oder V sind, da keine Zählung benötigt wird

=SI(A2="D";"Data",SI(A2="V";"Voice";"Autres")) 

Oder nach deinem Update:

=SI(GAUCHE(A2,1)="D";"Data",SI(GAUCHE(A2,1)="V";"Voice";"Autres")) 


1
2018-02-02 21:24



Das ist eigentlich eine Art Arbeit, aber die einzige Antwort ist "Autres". In Zeile A kann ich entweder Dxx oder Vxx haben. xx steht für Zahlen. Ich möchte die Zelle analysieren und mir sagen: "Wenn es D enthält, geben Sie Data ein, wenn es V enthält, geben Sie Voice ein, wenn es noch etwas enthält, geben Sie Autres ein. - Darksoulpk68
Die Felder werden nie genau = "D" sein (die Daten sind D1, D2 usw.). Es gibt eine Funktion namens (zumindest in Englisch) Left(string, length) Anstatt also den Wert von A2 zu testen, würden Sie nur das erste Zeichen von A2 testen: LEFT(A2,1)="D". Wenn Sie diese Änderung vornehmen, sollte die oben genannte Lösung funktionieren. - Yorik
Auch: COUNTIF würde positiv auf "D" für Strings wie "Not D2" testen - Yorik
Yorik hat meine Lösung gefunden! Vielen Dank. - Darksoulpk68


Yorik hat mir geholfen, die Antwort zu finden.

Ich habe die Formel verwendet:

=SI(GAUCHE(A2)="D";"Data";SI(GAUCHE(A2)="V";"Voice";"Autres"))

(Englisch:

=IF(LEFT(A2)="D";"Data";IF(LEFT(A2)="V";"Voice";"Autres"))

Und es hat perfekt funktioniert. Dies hat mir auch eine Lektion über die richtige Verwendung von Brackets und Zitaten gegeben! Danke SuperUsers :)


0
2018-02-03 18:33