Frage Die Tastatursprache ändert sich in Windows 10 ständig


Also habe ich kürzlich eine Neuinstallation von Windows 10 English vorgenommen. Ich habe es so konfiguriert, dass es eine englische Benutzeroberflächensprache aber eine norwegische Tastatur hat. Ich habe mehrere Probleme mit diesem Setup:

  1. Die Tastatursprache wechselt ständig auf Englisch
  2. Ich kann die Sprachleiste und das Popup-Fenster für die Sprachumschaltung beim Wechseln nicht sehen:

    language toggle popup

Ich habe das norwegische Tastaturlayout an gebunden Verschiebung+Alt+0 und das funktioniert, aber es ist nervig, das alle 5 Minuten machen zu müssen. Auch finde ich es komisch, dass ich die Sprachleiste weder auf dem Desktop noch auf der Toolbar sehen kann.

Hat jemand eine Vorstellung davon, was falsch sein könnte?

Hier sind einige Screenshots meiner Einstellungen:

settings 1

settings 2

settings 3

No language bar on the toolbar

P.S. Das einzige Mal, wenn ich das Sprachumschalt-Popup sehe, ist es, wenn ich im Sperrbildschirm abgemeldet bin und drücke Sieg+Raum. Nichts passiert, wenn ich das mache, nachdem ich eingeloggt bin.


230
2017-09-23 06:21


Ursprung


Das hat mich UP THE WALL angetrieben, seit ich Windows 10 installiert habe. Das Tastaturlayout wechselt sporadisch während ich tippe. Ich schwöre, ich habe die Verknüpfung <kbd> Win </ kbd> + <kbd> Space </ kbd> nicht berührt. - Colonel Panic
Alt + Shift ändert auch die Sprache. - Mir
Und Left Ctrl + Shift Ändert die Tastatur, wenn mehr als eine Tastatur installiert ist !! Alt + Shift und Ctrl + Shift sind gängige Verknüpfungsmuster in Code-Editoren und Adobe-Produkten (z. B. Photoshop). WINDOWS: Das war eine schlechte und unnötige Wahl der Shortcuts. Schäm dich. Ha! Kein Wunder, dass ich "neu starten" musste! Ich dachte, dieser neue Laptop / Tastatur wäre kaputt! Danke für alle die Lösung :) - SherylHohman
Es macht mich traurig, dass MSFT immer noch solche grundlegenden Usability-Probleme hat. - Bruno Brant


Antworten:


In Windows 10 wird standardmäßig gedrückt STRG+VERSCHIEBUNG (oder für einige ALT+VERSCHIEBUNG - Dank madmenyo) wird durch alle Tastaturlayouts, die Sie möglicherweise zugeordnet haben, durchlaufen und es ist überraschend einfach, dies versehentlich zu tun.

Wenn du weiter drückst STRG+VERSCHIEBUNG (oder was auch immer Sie es geändert haben mögen), dann sollten Sie bald zu der richtigen Einstellung zurückkehren. (alternativ neustarten, was ich erstmal gemacht habe ;-))

Sie können diese Standardtastaturaktion wie folgt deaktivieren:

Control Panel > Clock, Language, and Region > Language > Advanced settings > Switching input methods > Change language bar hotkeys > Change key sequence... > Switch keyboard layout > Not Assigned

ab 2016 hat sich der Standort geändert. (von Kommentaren)

Control panel > Language > Advanced settings > Switching input methods > Change language bar hot keys 

Seien Sie gewarnt, das oben beschriebene funktioniert nicht immer - Neustart und Ruhezustand können beide die Standardeinstellungen der Tastatur ändern (normalerweise in US) - Ich habe keine gusseiserne Lösung gefunden, obwohl die Erstellung eines neuen Profils hilfreich sein kann, aber keine besonders zufriedenstellende Antwort .

In einem Notfall

WIN+R  
osk

das Aufrufen der Bildschirmtastatur könnte vorübergehend helfen.

Beachten Sie auch, dass es möglich ist, dies zu deaktivieren, so dass keine Schlüsselkombination die Sprache ändert - ändern Sie die Schlüssel auf "Nicht zugewiesen" - siehe Antwort unten von Mort für weitere Informationen


314
2017-10-25 22:13



Waaaaat. Ich verwende in Visual Studio häufig Strg + Shift. Kein Wunder, dass sich mein Tastaturlayout ständig änderte. Vielen Dank! - willem
Für mich ist das tatsächlich ALT+SHIFT - Madmenyo
Ungerade. Vielleicht haben sie das geändert, aber für mich heißt es, die Tastenkombination zum Umschalten ist [Windows-Taste] + [Leerzeichen], was ein bisschen vernünftiger erscheint (und tatsächlich scheint es das einzige Ding zu sein, das als Sprachumschaltung funktioniert). - Nyerguds
Für alle, die im Jahr 2016 hierher kommen, scheint sich der Standort geändert zu haben. Jetzt ist es in Control panel//Language//Advanced settings//Switching input methods//Change language bar hot keys - David Metcalfe
um genau zu sein: win + space wechselt zwischen allen konfigurierten Sprach- / Tastaturpaaren. alt + shiftändert nur die Sprache und ctrl + shift ändert nur die Tastatur - Simon Zyx


Wenn Sie auf den Link "Tastaturkürzel ändern" klicken, der in Ihrem letzten Screenshot sichtbar ist, sollten Sie sehen können, welche Tasten die Tastatursprache ändern müssen.

Die Standardeinstellungen sind sehr leicht zu treffen, wenn man die Tastatur benutzt, wodurch plötzlich die Sprache der Tastatur geändert wird. Wenn Sie die Tasten auf "Nicht zugewiesen" setzen, wird verhindert, dass die Tastatursprache versehentlich umgeschaltet wird.


15
2017-09-29 10:03



Ja, diese wurden ursprünglich auf Shift + Alt eingestellt und dann habe ich sie in "none" geändert. Leider hat das das Problem nicht alleine gelöst, aber siehe meine andere Antwort. - Nilzor


Es stellte sich heraus, dass ich im ersten Screenshot ein Tastaturlayout konfigurieren musste. Sie werden feststellen, dass "Tastatur: Keine verfügbar" angezeigt wird. Klicken Sie hier auf "Optionen", dann auf "Hinzufügen einer Eingabemethode" und wählen Sie dann QWERTY Norwegisch.

Ich weiß nicht, wie ich Windows mit solch einem borked Sprachsetup installieren konnte. Jedenfalls rate ich jedem, sich die Sprachfragen bei der Erstinstallation genauer anzusehen.

Pic1

Pic2


12
2017-09-29 12:50



Nachdem ich versucht hatte, Handschrift in Französisch (in Kanada) zu bekommen, hatte ich 2 Versionen von Englisch (USA, Kanada) und Französisch (Frankreich, Kanada) installiert, ganz zu schweigen von mehr als einer Eingabemethode für Englisch US. Kurz gesagt, diese Antwort erlaubte mir, all das aufzuräumen. - Fuhrmanator


Die direkte Registrierungseinstellung zum Deaktivieren der Tastaturlayout-Tastenkombinationen lautet:

reg add "HKCU\Keyboard Layout\Toggle" /v "Layout Hotkey" /d 3

Vielleicht möchten Sie auch

reg add "HKCU\Keyboard Layout\Toggle" /v "Language Hotkey" /d 3
reg add "HKCU\Keyboard Layout\Toggle" /v "Hotkey" /d 3

Und für neue Benutzer versuchen Sie dies (in einer erhöhten Eingabeaufforderung):

reg load HKEY_USERS\temp "%USERPROFILE%\..\Default\NTUSER.DAT"
reg add "HKEY_USERS\temp\Keyboard Layout\Toggle" /v "Layout Hotkey" /d 3
reg unload HKEY_USERS\temp

9
2018-05-22 14:21



Was machen diese Befehle? - kleinfreund
@kleinfreund Wie im ersten Satz erwähnt, deaktiviert er die Tastaturkürzel, die das Layout umschalten, so dass es nicht versehentlich geändert werden kann. - mivk
Vielen Dank! Einen Insider-Build ausführen und den Sprachbereich vollständig aus der Systemsteuerung entfernen. Ich kann immer noch nicht verstehen, was Microsoft dazu gebracht hat, solch eine häufig verwendete Schlüsselkombination zu verwenden - samdd
Vielen Dank! Der einzige Weg, der 2018 funktioniert, um Alt-Shift / Strg-Shift Switching zu blockieren, scheint, dass die UI-Komponente, wo Sie sie ändern konnten, weg ist, ich kann sie nirgends finden. - jakub.g


Lösung1

benutze diese Lösung- Wie kann die automatische Änderung des Tastaturlayouts in Windows 8 deaktiviert werden? 

Lösung2

Wählen Sie die zweite Sprache als Standard. Wenn Sie dann zum ersten wechseln, bleibt es geschaltet.

(Danke an @SimonSeyock):

win + space wechselt zwischen allen Sprach- / Tastaturpaaren.  
alt + shift  ändert nur die Sprache  
ctrl + shift ändert nur die Tastatur


5
2018-03-19 07:13



Solution 1 bietet tatsächlich keine Lösung in diesem Link. Das löst ein Eingabe Methode keine Eingabesprache. - msysmilu
alt + shift hat es für mich getan. Nichts anderes hat wirklich funktioniert - Ghoti and Chips


Mein Problem: Ich habe 3 Sprachen (Tastaturlayouts) installiert. Wenn Sie in Windows 10 schlafen und dann aufwachen, wird immer die "Hauptsprache" verwendet, anstatt den letzten Satz beizubehalten. Ich halte das für einen Fehler.

Lösung:

  1. Öffnen Control Panel\All Control Panel Items\Language.
  2. Klicke auf Advanced Settings.
  3. Unter Switching input methods, Überprüf den Let me set a different input method for each app windows.

Dies wird die Sprache beibehalten, wenn Sie schlafen gehen und zurückkommen.


5
2018-05-04 03:56



Vielen Dank. Dies hat mein Problem gelöst, dass das Tastaturlayout nach dem Neustart und nach dem Schlafen immer wieder auf "Standard" zurückgesetzt wurde. Ich habe auch 3 Tastaturlayouts installiert. Englisch, weil es mit etwas Spiel und zwei Schwedisch besser funktioniert. Normal QWERTY und Dvorak. - Albert Veli
Ich hatte ein ähnliches Problem, löste es, indem ich meine Tastatur direkt unter Hauptsprache definierte: siehe superuser.com/a/1322521/97570 - jakub.g


2018 Antwort:

Ich hatte das gleiche Problem, indem ich versuchte, die polnische Tastatur mit der englischen Benutzeroberflächensprache von Windows zu verwenden.

Jedes Mal, wenn ich den Computer schloss, kam es zurück auf die US-Tastatur.

Das Problem war, dass ich polnische Tastatur unter polnischer Sprache hatte, wo ich eigentlich eine polnische Tastatur unter englischer Sprache wollte.

Ich habe das polnische Sprachpaket entfernt, die polnische Tastatur unter der englischen Sprache hinzugefügt und die amerikanische Tastatur aus der englischen Sprache entfernt - siehe Screenshot unten:

Windows 10 (2018) language preferences

Kurz gesagt, besteht der Trick darin, die gewünschte Tastatur als einzige Tastatur in der Standardsprache hinzuzufügen.

(Dies funktioniert für mich, weil ich generell Englisch eintippe, nur manchmal möchte ich Polnisch eingeben, aber ich kann es tun, ohne die Tastatur zu wechseln, da die polnische Tastatur voll mit US QWERTY kompatibel ist).


4
2018-05-14 12:43